[CakeML-dev] do_shift and others in semanticPrimitivesProps
Ramana.Kumar at cl.cam.ac.uk
Thu Dec 8 23:23:26 UTC 2016
I think I agree that they should be in semanticPrimitives instead...
Perhaps semanticPrimitives$do_app could be modified to actually use them also?
(I haven't looked too closely.)
On 9 December 2016 at 10:11, <Michael.Norrish at data61.csiro.au> wrote:
> Some backend/semantics files want to use the constants
> "do_shift", "do_word_from_int", "do_word_op", "do_word_to_int"
> These are defined in semanticPrimitivesProps. It seems like they’d be better placed in semanticPrimitives.
> What do people think?
> Developers mailing list
> Developers at cakeml.org
More information about the Developers